summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorTomasz Bursztyka <tomasz.bursztyka@linux.intel.com>2013-02-23 17:50:31 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2013-12-30 23:50:25 +0100
commit077785df023ad8947d44d19769bc6d91e3917633 (patch)
tree81edff765ee5eeb74997f2f1c4784058798776f0 /iptables/Makefile.am
parent1ff21a68502d67e056100da7e0da074467bc08ed (diff)
nft: Split nft core to become family independant
This makes nft core code independant from the family. Each family needs to implement and provide a struct nft_family_ops {}. This split will ease the future support of bridge and arp rules manipulations. [ updated header files and rebased upon the current tree --pablo ] Signed-off-by: Tomasz Bursztyka <tomasz.bursztyka@linux.intel.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 2ed16960..11c501b9 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -30,6 +30,7 @@ if HAVE_LIBMNL
if HAVE_LIBNFTABLES
xtables_multi_SOURCES += xtables-save.c xtables-restore.c \
xtables-standalone.c xtables.c nft.c \
+ nft-shared.c nft-ipv4.c nft-ipv6.c \
xtables-config-parser.y xtables-config-syntax.l \
xtables-config.c xtables-events.c
xtables_multi_LDADD += -lmnl -lnftables