summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-09-19 16:25:58 +0200
committerFlorian Westphal <fw@strlen.de>2018-11-13 12:12:51 +0100
commitd89cdfae64875c0ce33016e1342dcea4fbdc0323 (patch)
tree502d867d0d4ba04bad1f8a914b5f17d76ce5ff3d /iptables/Makefile.am
parent074e307e565f3804924541524d58d5f1fbb450bf (diff)
ip6tables-save: Merge into iptables-save.c
Both implementations were very similar already. Differences were mostly in which libiptc functions were called. Therefore introduce struct iptables_save_cb to point to the right functions for each variant. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index a21dadb7..4d59c489 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -13,18 +13,16 @@ if ENABLE_STATIC
xtables_legacy_multi_CFLAGS += -DALL_INCLUSIVE
endif
if ENABLE_IPV4
-xtables_legacy_multi_SOURCES += iptables-save.c \
- iptables-standalone.c iptables.c
+xtables_legacy_multi_SOURCES += iptables-standalone.c iptables.c
xtables_legacy_multi_CFLAGS += -DENABLE_IPV4
xtables_legacy_multi_LDADD += ../libiptc/libip4tc.la ../extensions/libext4.a
endif
if ENABLE_IPV6
-xtables_legacy_multi_SOURCES += ip6tables-save.c \
- ip6tables-standalone.c ip6tables.c
+xtables_legacy_multi_SOURCES += ip6tables-standalone.c ip6tables.c
xtables_legacy_multi_CFLAGS += -DENABLE_IPV6
xtables_legacy_multi_LDADD += ../libiptc/libip6tc.la ../extensions/libext6.a
endif
-xtables_legacy_multi_SOURCES += xshared.c iptables-restore.c
+xtables_legacy_multi_SOURCES += xshared.c iptables-restore.c iptables-save.c
xtables_legacy_multi_LDADD += ../libxtables/libxtables.la -lm
# iptables using nf_tables api