summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2022-12-03 23:20:58 +0100
committerPhil Sutter <phil@nwl.cc>2022-12-14 15:47:08 +0100
commit127eadee563e4e7b741dc532e0b70b7dabf5481c (patch)
treed082354d2ff3424f97251aba20f59b0138141713 /iptables/Makefile.am
parent53153775b08f830b940d04efbc7b38bc40aaa4b3 (diff)
Makefile: Generate ip6tables man pages on the fly
No need to drag them around, creating them is simple. Signed-off-by: Phil Sutter <phil@nwl.cc>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 23f8352d..8c346698 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -105,6 +105,9 @@ iptables-extensions.8: iptables-extensions.8.tmpl ../extensions/matches.man ../e
iptables-translate.8 ip6tables-translate.8 iptables-restore-translate.8 ip6tables-restore-translate.8:
${AM_VERBOSE_GEN} echo '.so man8/xtables-translate.8' >$@
+ip6tables.8 ip6tables-apply.8 ip6tables-restore.8 ip6tables-save.8:
+ ${AM_VERBOSE_GEN} echo "$@" | sed 's|^ip6|.so man8/ip|' >$@
+
pkgconfig_DATA = xtables.pc
# Using if..fi avoids an ugly "error (ignored)" message :)