summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2022-12-05 18:56:09 +0100
committerPhil Sutter <phil@nwl.cc>2022-12-14 15:47:14 +0100
commite10f1a2a2d8756c9e9924c9328d507daab14a0ef (patch)
tree540ac26709fccbab6276d2c57234e5e01d9cbbfa /iptables/Makefile.am
parenta8c50458cf5572c3ec3841bdeb0ec01058df476c (diff)
iptables/Makefile: Split nft-variant man page list
Some of them are not generated and must therefore be distributed. Hence add them to a 'dist_man_MANS' variable. This leaves only generated entries in the non-dist one, so use that to reduce the CLEANFILES list. Signed-off-by: Phil Sutter <phil@nwl.cc>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 77202ad8..7ca2b1a4 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -66,19 +66,15 @@ man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
sbin_SCRIPTS = iptables-apply
if ENABLE_NFTABLES
-man_MANS += xtables-nft.8 xtables-translate.8 xtables-legacy.8 \
- iptables-translate.8 ip6tables-translate.8 \
+man_MANS += iptables-translate.8 ip6tables-translate.8 \
iptables-restore-translate.8 ip6tables-restore-translate.8 \
- xtables-monitor.8 \
- arptables-nft.8 arptables-nft-restore.8 arptables-nft-save.8 \
- ebtables-nft.8
+ xtables-monitor.8
+
+dist_man_MANS = xtables-nft.8 xtables-translate.8 xtables-legacy.8 \
+ arptables-nft.8 arptables-nft-restore.8 arptables-nft-save.8 \
+ ebtables-nft.8
endif
-CLEANFILES = iptables.8 xtables-monitor.8 \
- iptables-xml.1 iptables-apply.8 \
- iptables-extensions.8 iptables-extensions.8.tmpl \
- iptables-restore.8 iptables-save.8 \
- iptables-restore-translate.8 ip6tables-restore-translate.8 \
- iptables-translate.8 ip6tables-translate.8
+CLEANFILES = ${man_MANS} iptables-extensions.8.tmpl
vx_bin_links = iptables-xml
if ENABLE_IPV4