summaryrefslogtreecommitdiffstats
path: root/libiptc/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2019-05-28 11:18:32 +0200
committerFlorian Westphal <fw@strlen.de>2019-05-30 22:43:13 +0200
commita84b12c69dcd57eb7df19e59b85af0fb5d98a81b (patch)
tree1b8298d95936006d2491ce9656c4b7ec31c62ff2 /libiptc/Makefile.am
parent1447b15100fe73810237809c1d4ade3c861b6d96 (diff)
build: remove -Wl,--no-as-needed and libiptc.so
Despite the presence of --no-as-needed, the libiptc.so library as produced inside the openSUSE Build Service has no links to libip4tc.so or libip6tc.so. I have not looked into why --no-as-needed is ignored in this instance, but likewise, the situation must have been like that ever since openSUSE made as-needed a distro-wide default (gcc 4.8 timeframe or so). Since I am not aware of any problem reports within SUSE/openSUSE about this whole situation, it seems safe to assume no one in the larger scope is still using a bare "-liptc" on the linker command line and that all parties have moved on to using pkg-config. Therefore, libiptc.la/so is hereby removed, as are all parts related to the -Wl,--no-as-needed flag. Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'libiptc/Makefile.am')
-rw-r--r--libiptc/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/libiptc/Makefile.am b/libiptc/Makefile.am
index 638295db..464a0696 100644
--- a/libiptc/Makefile.am
+++ b/libiptc/Makefile.am
@@ -5,11 +5,8 @@ AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}
pkgconfig_DATA = libiptc.pc libip4tc.pc libip6tc.pc
-lib_LTLIBRARIES = libip4tc.la libip6tc.la libiptc.la
-libiptc_la_SOURCES =
-libiptc_la_LIBADD = libip4tc.la libip6tc.la
-libiptc_la_LDFLAGS = -version-info 0:0:0 ${libiptc_LDFLAGS2}
+lib_LTLIBRARIES = libip4tc.la libip6tc.la
libip4tc_la_SOURCES = libip4tc.c
libip4tc_la_LDFLAGS = -version-info 2:0:0
libip6tc_la_SOURCES = libip6tc.c
-libip6tc_la_LDFLAGS = -version-info 2:0:0 ${libiptc_LDFLAGS2}
+libip6tc_la_LDFLAGS = -version-info 2:0:0