summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 742e3de0..5465db6c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,3 +107,8 @@ tarball:
rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};
config.status: include/xtables.h.in
+
+# ldconfig may fail when we are not root (as is the case in build systems)
+# so add appropriate protection that it does not let `make` fail.
+install-exec-hook:
+ -/sbin/ldconfig || :;