summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-09-12 10:56:34 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2010-09-12 10:56:34 +0200
commitaf42a8de4c62e0d3d8d78c15935d4d34fc123a5b (patch)
tree0a947e7531bde4f11b107523b68cec4e24b3ebfb /configure.ac
parentdd1b4e9d405413fbaebae1dac16b012391136924 (diff)
build: run AC_CANONICAL_HOST only
There is no need to call AC_CANONICAL_SYSTEM when only AC_CANONICAL_HOST is needed. Also, checking for $target is factually incorrect, since we do not produce object code like a compiler. Use $host, which specifies the triple/quadrople where the compiled program is supposed to run. Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eda4c14..fe5b6fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to create configure.
AC_INIT([libnetfilter_conntrack], [0.9.0])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([-Wall foreign subdir-objects dist-bzip2 1.6])
@@ -13,7 +13,7 @@ AC_PROG_LN_S
AC_SUBST(LIBTOOL_DEPS)
-case $target in
+case "$host" in
*-*-linux*) ;;
*) AC_MSG_ERROR([Linux only, dude!]);;
esac