summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-31 10:10:30 +0100
committerJan Engelhardt <jengelh@medozas.de>2010-10-31 10:10:30 +0100
commitcaac08128586a7e4d84744ad9367af81f74bde63 (patch)
tree9516ffa14ddcec1a5da92faa115d1b70d1f8b663 /configure.ac
parentbf3dc4c7db95ff7203bc6257f73efa0a28e720f4 (diff)
build: run autoupdate to replace obsolete constructs
Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d0145bd..b194ea8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,8 +28,7 @@ AC_CHECK_FUNCS(inet_ntop)
dnl Again, some systems have it, but not IPv6
if test "$ac_cv_func_inet_ntop" = "yes" ; then
AC_MSG_CHECKING(if inet_ntop supports IPv6)
-AC_TRY_RUN(
- [
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif
@@ -52,9 +51,9 @@ int main()
else
exit(0);
}
- ], [ AC_MSG_RESULT(yes)
+ ]])],[ AC_MSG_RESULT(yes)
AC_DEFINE_UNQUOTED(HAVE_INET_NTOP_IPV6, 1, [Define to 1 if inet_ntop supports IPv6.])
- ], AC_MSG_RESULT(no),AC_MSG_RESULT(no))
+ ],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(no)])
fi
if test ! -z "$libdir"; then