summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-30 23:50:50 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-30 23:53:11 +0200
commit88c7a6cc3ae343e3ff75b041a6d84dcfd840e884 (patch)
tree2d39b4150ffc6d94ccfcd156cd6b5288b99ce61b /configure.ac
parente45b515d6e4deddac28144ae228e8241320a2277 (diff)
build: no need for error message in PKG_CHECK_MODULES
PKG_CHECK_MODULES already produces its own (and more verbose) messsage when a module cannot be found. Mucking around with CFLAGS and LIBS is also not needed since pkgconfig takes care of providing variables, so let's use them in Makefile.am. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index d5b65af..429f0a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,14 +19,6 @@ case "$host" in
esac
dnl Dependencies
-AC_CHECK_PROG(HAVE_PKG_CONFIG, pkg-config, yes)
-if test "x$HAVE_PKG_CONFIG" = "x"
-then
- echo "*** Error: No suitable pkg-config found. ***"
- echo " Please install the 'pkg-config' package."
- exit 1
-fi
-
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 1.0.0])
AC_CHECK_HEADERS(arpa/inet.h)
@@ -69,11 +61,6 @@ if test ! -z "$libdir"; then
CFLAGS="$CFLAGS -DLIBNETFILTER_CONNTRACK_DIR=$MODULE_DIR"
fi
-CFLAGS="$CFLAGS $LIBNFNETLINK_CFLAGS"
-LIBNFCONNTRACK_LIBS="$LIBNFNETLINK_LIBS"
-
-AC_SUBST(LIBNFCONNTRACK_LIBS)
-
dnl Output the makefile
AC_OUTPUT(Makefile src/Makefile include/Makefile utils/Makefile qa/Makefile include/libnetfilter_conntrack/Makefile include/internal/Makefile src/conntrack/Makefile src/expect/Makefile libnetfilter_conntrack.pc doxygen.cfg)