summaryrefslogtreecommitdiffstats
path: root/l3extensions/Makefile.am
diff options
context:
space:
mode:
author/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=pablo/emailAddress=pablo@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=pablo/emailAddress=pablo@netfilter.org>2005-12-26 02:29:02 +0000
committer/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=pablo/emailAddress=pablo@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=pablo/emailAddress=pablo@netfilter.org>2005-12-26 02:29:02 +0000
commit8aa719eb1afb6c6e0a5bf74cbdab79dc82da6c80 (patch)
treed297a64f5ff25395981334035d5deae8d13e69cc /l3extensions/Makefile.am
parent5875e04f38e0e5c09e497dc735e287fc6cc626b3 (diff)
o add IPv6 support
o clean up layer-4 compare functions o finish the comparison infrastructure: support for tuple/mark matching o fix bug in the default event display when used in conjunction with the comparison infrastructure. o Bumped version to 0.0.30 Thanks to Yasuyuki Kozakai for: [LIBNETFILTER_CONNTRACK] fix dumping IPv6 connections that in included in this commit.
Diffstat (limited to 'l3extensions/Makefile.am')
-rw-r--r--l3extensions/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/l3extensions/Makefile.am b/l3extensions/Makefile.am
new file mode 100644
index 0000000..fa21b2d
--- /dev/null
+++ b/l3extensions/Makefile.am
@@ -0,0 +1,16 @@
+include $(top_srcdir)/Make_global.am
+
+AUTOMAKE_OPTIONS = no-dependencies foreign
+
+AM_CFLAGS=-fPIC -Wall
+LIBS=
+
+pkglib_LTLIBRARIES = nfct_l3proto_ipv4.la nfct_l3proto_ipv6.la
+
+nfct_l3proto_ipv4_la_SOURCES = libnetfilter_conntrack_ipv4.c
+nfct_l3proto_ipv4_la_LDFLAGS = -module -avoid-version -release $(VERSION)
+nfct_l3proto_ipv4_la_LIBADD = ../src/libnetfilter_conntrack.la
+
+nfct_l3proto_ipv6_la_SOURCES = libnetfilter_conntrack_ipv6.c
+nfct_l3proto_ipv6_la_LDFLAGS = -module -avoid-version -release $(VERSION)
+nfct_l3proto_ipv6_la_LIBADD = ../src/libnetfilter_conntrack.la