summaryrefslogtreecommitdiffstats
path: root/qa/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2012-03-06 12:10:55 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2012-03-06 12:10:55 +0100
commit94e75add9867fb6f0e05e73b23f723f139da829e (patch)
treef190e2dae69449c0a6ca547e629a8fd5356116b1 /qa/Makefile.am
parent62ed08f2d25ef0f332fe65fd40a97ff4dc4eda93 (diff)
qa: add some stress tools to test conntrack via ctnetlink
ct_stress adds plenty of flows in assured state (worst case for the conntrack table). ct_events_reliable forces reliable event delivery. You have to use this tools together: ./ct_events_reliable & then: ./ct_stress 65535 # your ct table size If things go well, you will end up hitting ENOMEM. Both as root, of course. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'qa/Makefile.am')
-rw-r--r--qa/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/qa/Makefile.am b/qa/Makefile.am
index 2bf568a..cb49aa4 100644
--- a/qa/Makefile.am
+++ b/qa/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/Make_global.am
-check_PROGRAMS = test_api test_filter
+check_PROGRAMS = test_api test_filter ct_stress ct_events_reliable
test_api_SOURCES = test_api.c
test_api_LDADD = ../src/libnetfilter_conntrack.la
@@ -9,3 +9,11 @@ test_api_LDFLAGS = -dynamic -ldl
test_filter_SOURCES = test_filter.c
test_filter_LDADD = ../src/libnetfilter_conntrack.la
test_filter_LDFLAGS = -dynamic -ldl
+
+ct_stress_SOURCES = ct_stress.c
+ct_stress_LDADD = ../src/libnetfilter_conntrack.la
+ct_stress_LDFLAGS = -dynamic -ldl
+
+ct_events_reliable_SOURCES = ct_events_reliable.c
+ct_events_reliable_LDADD = ../src/libnetfilter_conntrack.la
+ct_events_reliable_LDFLAGS = -dynamic -ldl