summaryrefslogtreecommitdiffstats
path: root/qa/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2008-11-25 01:03:19 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2008-11-25 01:03:19 +0100
commit20506e55b12ba22b761a1ad84dc8a47ce8c82f2e (patch)
treea23824017b20e4161e6310fefdfd0a20503fca99 /qa/Makefile.am
parent972e6b3c19f3c79b59804308efac447bd2d016ec (diff)
bsf: major rework of the BSF generation code
This patch reworks the BSF automatic generation code. This feature needs more love and it has several limitations like that the maximum number of IPs are 127 due to BSF code restrictions. See this patch as a first step forward. This patch also adds the stack data type, which is used to resolve jump dynamically instead of the previous static approach. This patch also includes fixes in the limitations, previous calculations were wrong. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'qa/Makefile.am')
-rw-r--r--qa/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/qa/Makefile.am b/qa/Makefile.am
index 6a9471b..2bf568a 100644
--- a/qa/Makefile.am
+++ b/qa/Makefile.am
@@ -1,7 +1,11 @@
include $(top_srcdir)/Make_global.am
-check_PROGRAMS = test_api
+check_PROGRAMS = test_api test_filter
test_api_SOURCES = test_api.c
test_api_LDADD = ../src/libnetfilter_conntrack.la
test_api_LDFLAGS = -dynamic -ldl
+
+test_filter_SOURCES = test_filter.c
+test_filter_LDADD = ../src/libnetfilter_conntrack.la
+test_filter_LDFLAGS = -dynamic -ldl