summaryrefslogtreecommitdiffstats
path: root/qa/Makefile.am
diff options
context:
space:
mode:
authorKen-ichirou MATSUZAWA <chamaken@gmail.com>2015-03-13 07:24:19 +0900
committerFlorian Westphal <fw@strlen.de>2015-03-13 14:37:51 +0100
commit4ef7e4e64b6a5f15f949c678ec096465da202573 (patch)
tree9a0a8294a80c68e0365c9d89fd3319a2a5ef6c7f /qa/Makefile.am
parentc44b4657fa84d66423c19a4e60e5ef9d1633daeb (diff)
qa: add test for mark event filter
testing mark filter in root by # ./qa/ct_mark_filter.sh Signed-off-by: Ken-ichirou MATSUZAWA <chamas@h4.dion.ne.jp> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'qa/Makefile.am')
-rw-r--r--qa/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/qa/Makefile.am b/qa/Makefile.am
index b16ab01..3c8a1cb 100644
--- a/qa/Makefile.am
+++ b/qa/Makefile.am
@@ -1,7 +1,7 @@
include $(top_srcdir)/Make_global.am
check_PROGRAMS = test_api test_filter test_connlabel ct_stress \
- ct_events_reliable ct_echo_event
+ ct_events_reliable ct_echo_event ct_mark_filter
test_api_SOURCES = test_api.c
test_api_LDADD = ../src/libnetfilter_conntrack.la
@@ -22,3 +22,7 @@ AM_CFLAGS += -D_GNU_SOURCE
ct_echo_event_SOURCES = ct_echo_event.c nssocket.c
ct_echo_event_DEPENDENCIES = ct_echo_event.sh
ct_echo_event_LDADD = ../src/libnetfilter_conntrack.la -lmnl
+
+ct_mark_filter_SOURCES = ct_mark_filter.c nssocket.c
+ct_mark_filter_DEPENDENCIES = ct_mark_filter.sh
+ct_mark_filter_LDADD = ../src/libnetfilter_conntrack.la -lmnl