summaryrefslogtreecommitdiffstats
path: root/src/conntrack/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2008-10-30 20:44:25 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2008-10-30 20:44:25 +0100
commit7dd5289076160ee2844978bfd1640ca7aa34f4da (patch)
treea91a1c1dcea8238bf01f933352f41526f6581ba0 /src/conntrack/Makefile.am
parent215d42fef86577ad74151cda553a20b1bdb58a30 (diff)
groups: add attribute group API
This new API allows you to set and get some logical set of attributes. This is not intended to replace the existing per-attribute get/set API but to provide more efficient way to get/set certain attributes. This change includes an example file (conntrack_grp_create.c) of the use of the attribute group API. See ATTR_GRP_* for more information on the existing groups. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/conntrack/Makefile.am')
-rw-r--r--src/conntrack/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/conntrack/Makefile.am b/src/conntrack/Makefile.am
index 94009ea..2d62177 100644
--- a/src/conntrack/Makefile.am
+++ b/src/conntrack/Makefile.am
@@ -13,4 +13,5 @@ libnfconntrack_la_SOURCES = api.c callback.c \
objopt.c \
compare.c \
copy.c \
- filter.c bsf.c
+ filter.c bsf.c \
+ grp.c grp_getter.c grp_setter.c