summaryrefslogtreecommitdiffstats
path: root/src/conntrack/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2010-10-12 13:24:08 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2010-11-08 23:40:33 +0100
commitb245e4092c5a7f09729e64868a42e13f48ac5db8 (patch)
treea31692d718120b9c17951e2e583c3a7d554602ab /src/conntrack/Makefile.am
parent417dc5fb87ade355d699ea523de870abc6dd1657 (diff)
src: allow to use nfct handler for conntrack and expectations at the same time
This patch re-works the callback handling to allow the use the same socket to send/receive commands and listen to events of both conntrack and expectation subsystems. Now you can register one callback for conntrack and one for expectation with the same handler with no problems (before this patch, this was not possible, you required two different handlers). Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/conntrack/Makefile.am')
-rw-r--r--src/conntrack/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/conntrack/Makefile.am b/src/conntrack/Makefile.am
index 68c2d72..34afefb 100644
--- a/src/conntrack/Makefile.am
+++ b/src/conntrack/Makefile.am
@@ -4,7 +4,7 @@ AM_CFLAGS = -Wall ${LIBNFNETLINK_CFLAGS}
noinst_LTLIBRARIES = libnfconntrack.la
-libnfconntrack_la_SOURCES = api.c callback.c \
+libnfconntrack_la_SOURCES = api.c \
getter.c setter.c \
parse.c build.c \
snprintf.c \