summaryrefslogtreecommitdiffstats
path: root/src/expect/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2012-04-16 12:13:45 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2012-05-26 16:11:35 +0200
commitd773fb2afc097a08d51eae42740c63142b1752cf (patch)
tree83d60033ed8124ebe77b2993b12c309e94a1433c /src/expect/Makefile.am
parent95b3bf6576165e1bbe23d55d5f15b7ebf9c98dc4 (diff)
expect: add new API to build/parse ctnetlink messages using libmnl
This patch adds support to build and to parse netlink messages from/to one user-space nf_conntrack object. It uses libmnl, thus libnetfilter_conntrack now depends on this library. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/expect/Makefile.am')
-rw-r--r--src/expect/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/expect/Makefile.am b/src/expect/Makefile.am
index e8a874a..61d5cbd 100644
--- a/src/expect/Makefile.am
+++ b/src/expect/Makefile.am
@@ -8,4 +8,7 @@ libnfexpect_la_SOURCES = api.c \
parse.c build.c \
snprintf.c \
snprintf_default.c \
- snprintf_xml.c
+ snprintf_xml.c \
+ build_mnl.c \
+ parse_mnl.c
+