summaryrefslogtreecommitdiffstats
path: root/l3extensions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'l3extensions/Makefile.am')
-rw-r--r--l3extensions/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/l3extensions/Makefile.am b/l3extensions/Makefile.am
new file mode 100644
index 0000000..fa21b2d
--- /dev/null
+++ b/l3extensions/Makefile.am
@@ -0,0 +1,16 @@
+include $(top_srcdir)/Make_global.am
+
+AUTOMAKE_OPTIONS = no-dependencies foreign
+
+AM_CFLAGS=-fPIC -Wall
+LIBS=
+
+pkglib_LTLIBRARIES = nfct_l3proto_ipv4.la nfct_l3proto_ipv6.la
+
+nfct_l3proto_ipv4_la_SOURCES = libnetfilter_conntrack_ipv4.c
+nfct_l3proto_ipv4_la_LDFLAGS = -module -avoid-version -release $(VERSION)
+nfct_l3proto_ipv4_la_LIBADD = ../src/libnetfilter_conntrack.la
+
+nfct_l3proto_ipv6_la_SOURCES = libnetfilter_conntrack_ipv6.c
+nfct_l3proto_ipv6_la_LDFLAGS = -module -avoid-version -release $(VERSION)
+nfct_l3proto_ipv6_la_LIBADD = ../src/libnetfilter_conntrack.la