summaryrefslogtreecommitdiffstats
path: root/src/deprecated/extensions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/deprecated/extensions/Makefile.am')
-rw-r--r--src/deprecated/extensions/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/deprecated/extensions/Makefile.am b/src/deprecated/extensions/Makefile.am
new file mode 100644
index 0000000..e44525b
--- /dev/null
+++ b/src/deprecated/extensions/Makefile.am
@@ -0,0 +1,14 @@
+include $(top_srcdir)/Make_global.am
+
+AUTOMAKE_OPTIONS = no-dependencies foreign
+
+AM_CFLAGS=-fPIC -Wall
+LIBS= @LIBNFCONNTRACK_LIBS@
+
+noinst_LTLIBRARIES = libnfct_proto_tcp.la libnfct_proto_udp.la \
+ libnfct_proto_icmp.la libnfct_proto_sctp.la
+
+libnfct_proto_tcp_la_SOURCES = libnetfilter_conntrack_tcp.c
+libnfct_proto_udp_la_SOURCES = libnetfilter_conntrack_udp.c
+libnfct_proto_icmp_la_SOURCES = libnetfilter_conntrack_icmp.c
+libnfct_proto_sctp_la_SOURCES = libnetfilter_conntrack_sctp.c