summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-10-09 12:38:34 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2021-10-12 00:59:15 +0200
commit86f8c16559a20a6e6d0129acc4a04d43ead7c7b0 (patch)
tree78be7a57de257d18ee6189544ee39c1ca986cbdb /utils/Makefile.am
parent0e075c08c04b21444b38a430af84dc5b7537d321 (diff)
build: move dependency CFLAGS variables out of `AM_CPPFLAGS`
`${LIBNFNETLINK_CFLAGS}` and `${LIBMNL_CFLAGS}` are not required for all libraries and executables: include them only where necessary. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 39abb3e..133b6ec 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -6,12 +6,13 @@ nfulnl_test_SOURCES = nfulnl_test.c
nfulnl_test_LDADD = ../src/libnetfilter_log.la
nfulnl_test_LDFLAGS = -dynamic
-nf_log_SOURCES = nf-log.c
-nf_log_LDADD = ../src/libnetfilter_log.la $(LIBMNL_LIBS)
-nf_log_LDFLAGS = -dynamic
+nf_log_SOURCES = nf-log.c
+nf_log_LDADD = ../src/libnetfilter_log.la $(LIBMNL_LIBS)
+nf_log_LDFLAGS = -dynamic
+nf_log_CPPFLAGS = $(AM_CPPFLAGS) $(LIBMNL_CFLAGS)
if BUILD_NFCT
-nf_log_LDADD += $(LIBNETFILTER_CONNTRACK_LIBS)
-nf_log_CPPFLAGS = ${AM_CPPFLAGS} ${LIBNETFILTER_CONNTRACK_CFLAGS} -DBUILD_NFCT
+nf_log_LDADD += $(LIBNETFILTER_CONNTRACK_LIBS)
+nf_log_CPPFLAGS += $(LIBNETFILTER_CONNTRACK_CFLAGS) -DBUILD_NFCT
endif
if BUILD_IPULOG