summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index a907241..ca25c1a 100644
--- a/configure.in
+++ b/configure.in
@@ -7,8 +7,10 @@ AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(libnfnetlink_log, 0.10)
AC_PROG_CC
-AC_EXEEXT
AM_PROG_LIBTOOL
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
AC_SUBST(LIBTOOL_DEPS)
case $target in
@@ -20,9 +22,6 @@ AC_CHECK_LIB([nfnetlink], [nfnl_listen])
-dnl Output the makefile
-AC_OUTPUT(Makefile src/Makefile include/Makefile utils/Makefile)
-
dnl--------------------------------
AC_DEFUN([NF_KERNEL_SOURCE],[
@@ -60,11 +59,9 @@ AC_ARG_WITH(kernel,
[ Show location of kernel source. Default is to use uname -r and look in /lib/modules/KERNEL/build/include. ]),
NF_KERNEL_SOURCE($with_kernel),NF_KERNEL_SOURCE())
-if test ! -z "$libdir"; then
- MODULE_DIR="\\\"$libdir/\\\""
- CFLAGS="$CFLAGS -DCONNTRACK_LIB_DIR=$MODULE_DIR"
-fi
-
dnl--------------------------------
+dnl Output the makefile
+AC_OUTPUT(Makefile src/Makefile include/Makefile utils/Makefile)
+