summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-30 23:07:13 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-30 23:56:06 +0200
commit9eefb0cf3ca7ecf10d0ad28de3413f39ac4438ef (patch)
tree8015485ed35deb46200a9a814674e0d02f796750 /configure.ac
parent06d7168caf9304fb825275b983b534fede836ee4 (diff)
build: run AC_CANONICAL_HOST only
There is no need to call AC_CANONICAL_SYSTEM when only AC_CANONICAL_HOST is needed. Also, checking for $target is factually incorrect, since we do not produce object code like a compiler. Use $host, which specifies the triple/quadrople where the compiled program is supposed to run. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3bd3e1c..7c3468b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to create configure.
AC_INIT([libnetfilter_queue], [1.0.0])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([-Wall foreign subdir-objects dist-bzip2 1.6])
@@ -13,7 +13,7 @@ AC_PROG_INSTALL
AC_SUBST(LIBTOOL_DEPS)
-case $target in
+case "$host" in
*-*-linux*) ;;
*) AC_MSG_ERROR([Linux only, dude!]);;
esac