summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorYang Zheng <tomsun.0.7@gmail.com>2018-03-20 22:53:22 +0800
committerPablo Neira Ayuso <pablo@netfilter.org>2018-03-20 16:31:03 +0100
commit726031795f23a69f104cba0e8a9dfacf2d4f698a (patch)
tree7931feb1ee49d0ce5824d028f4cf13769f5347bb /examples/Makefile.am
parent62d6fff78b2cb2a0c9d59e18e7047a45f1ffdbbc (diff)
examples: add nft-ct-helper-{add,get,del}
nft-ct-helper-{add,get,del}: add, get, or delete ct helper objects from the specified table. Examples: % ./nft-ct-helper-get ip filter <nothing> % ./nft-ct-helper-add ip filter sip-5060 sip udp % ./nft-ct-helper-get ip filter table filter name sip-5060 use 0 [ ct_helper name sip family 2 protocol 17 ] % ./nft-ct-helper-del ip filter sip-5060 % ./nft-ct-helper-get ip filter <nothing> Signed-off-by: Yang Zheng <tomsun.0.7@gmail.com> Acked-by: Arturo Borrero Gonzalez <arturo@netfilter.org> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index c0d84eb..96112e7 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -30,7 +30,10 @@ check_PROGRAMS = nft-table-add \
nft-flowtable-get \
nft-ruleset-get \
nft-ruleset-parse-file \
- nft-compat-get
+ nft-compat-get \
+ nft-ct-helper-add \
+ nft-ct-helper-get \
+ nft-ct-helper-del
nft_table_add_SOURCES = nft-table-add.c
nft_table_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
@@ -124,3 +127,12 @@ nft_ruleset_parse_file_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_compat_get_SOURCES = nft-compat-get.c
nft_compat_get_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
+nft_ct_helper_add_SOURCES = nft-ct-helper-add.c
+nft_ct_helper_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
+nft_ct_helper_get_SOURCES = nft-ct-helper-get.c
+nft_ct_helper_get_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
+nft_ct_helper_del_SOURCES = nft-ct-helper-del.c
+nft_ct_helper_del_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}