summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2012-11-11 22:53:57 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2012-11-11 23:32:08 +0100
commit682b656b5749507bc0db7dbf172b822dbf474d44 (patch)
treef179840cf776eecfa2bc4868422fc3b88b59ad3c /examples/Makefile.am
parenta7490c7b24f39a88798fed66a6f15fd8e0e7f9ae (diff)
examples: table: add example of dormant tables
Now we add a non-dormant table which is not active. We can add chains and rules to it that would not have any effect. Once we change the flag to wake it up, the rule-set becomes active. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 9b9e345..aee95df 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,6 +1,7 @@
include $(top_srcdir)/Make_global.am
check_PROGRAMS = nft-table-add \
+ nft-table-upd \
nft-table-del \
nft-table-get \
nft-chain-add \
@@ -15,6 +16,9 @@ check_PROGRAMS = nft-table-add \
nft_table_add_SOURCES = nft-table-add.c
nft_table_add_LDADD = ../src/libnftables.la ${LIBMNL_LIBS}
+nft_table_upd_SOURCES = nft-table-upd.c
+nft_table_upd_LDADD = ../src/libnftables.la ${LIBMNL_LIBS}
+
nft_table_del_SOURCES = nft-table-del.c
nft_table_del_LDADD = ../src/libnftables.la ${LIBMNL_LIBS}