summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2015-02-13 18:01:02 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2015-02-17 19:25:11 +0100
commit26c945057d742fc4b0f4dfdc07849074cb9264c1 (patch)
tree20facafe81106096f8ee1ca954fe0e59b8e8c664 /include/Makefile.am
parent007e93ea118436eb40a2e39d6ae185c14b74ecf1 (diff)
src: split internal.h is smaller files
The internal.h file started being a small file with private definitions. Its size has been increasing over time more and more, so let's split this in small header files that map to the corresponding class where the functions belong to. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 102d5ab..be9eb9b 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,4 +1,15 @@
SUBDIRS = libnftnl linux
-noinst_HEADERS = linux_list.h \
- buffer.h
+noinst_HEADERS = internal.h \
+ linux_list.h \
+ buffer.h \
+ data_reg.h \
+ expr_ops.h \
+ linux_list.h \
+ set.h \
+ xml.h \
+ common.h \
+ expr.h \
+ json.h \
+ set_elem.h \
+ utils.h