summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 54c66fe..f95b268 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,12 +20,14 @@ AC_ARG_WITH([xml-parsing],
AC_ARG_WITH([json-parsing],
AS_HELP_STRING([--with-json-parsing], [JSON parsing support]))
-AS_IF([test "x$with_xml_parsing" = "xyes"], [
- PKG_CHECK_MODULES([LIBXML], [mxml >= 2.6])
-])
-AS_IF([test "x$with_json_parsing" = "xyes"], [
- PKG_CHECK_MODULES([LIBJSON], [jansson >= 2.3])
-])
+AS_IF([test "x$with_xml_parsing" = "xyes"],
+ [PKG_CHECK_MODULES([LIBXML], [mxml >= 2.6])],
+ [with_xml_parsing="no"]
+)
+AS_IF([test "x$with_json_parsing" = "xyes"],
+ [PKG_CHECK_MODULES([LIBJSON], [jansson >= 2.3])],
+ [with_json_parsing="no"]
+)
AC_PROG_CC
AM_PROG_CC_C_O
AC_EXEEXT