summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2017-11-14 21:17:10 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2017-11-16 14:35:35 +0100
commit90417cc148e01b746957dbcf375daa3378a50c58 (patch)
treeb149997074b13e715766fc2a7713c392d1ddef0b /configure.ac
parent9200bfc50653612033d58774f422fc20150d3301 (diff)
libnftables: Split code into frontend and library
This finally creates the libnftables shared object. For some reason, this causes two compiler warnings to appear: | parser_bison.y: In function 'nft_parse': | parser_bison.y:131:3: warning: implicit declaration of function 'nft_set_debug' [-Wimplicit-function-declaration] | nft_set_debug(1, scanner); | ^~~~~~~~~~~~~ | parser_bison.c:64:25: warning: implicit declaration of function 'nft_lex' [-Wimplicit-function-declaration] | #define yylex nft_lex | ^ | parser_bison.c:4745:16: note: in expansion of macro 'yylex' | yychar = yylex (&yylval, &yylloc, scanner); So this patch contains a workaround, namely declaring both functions in src/parser_bison.y. During linking the objects are found, so this is rather a matter of cosmetics. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 099a4a5e..a97d9e73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,9 @@ then
exit 1
fi
+AM_PROG_AR
+AM_PROG_LIBTOOL
+
AC_CHECK_PROG(DOCBOOK2X_MAN, [docbook2x-man], [docbook2x-man], [no])
AC_CHECK_PROG(DOCBOOK2MAN, [docbook2man], [docbook2man], [no])
AC_CHECK_PROG(DB2X_DOCBOOK2MAN, [db2x_docbook2man], [db2x_docbook2man], [no])
@@ -138,6 +141,7 @@ AC_CHECK_FUNCS([memmove memset strchr strdup strerror strtoull])
AC_CONFIG_FILES([ \
Makefile \
+ libnftables.pc \
src/Makefile \
include/Makefile \
include/nftables/Makefile \