summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVarsha Rao <rvarsha016@gmail.com>2018-01-19 08:30:17 +0530
committerPablo Neira Ayuso <pablo@netfilter.org>2018-01-19 13:06:53 +0100
commit4c19685e0f29207fd70747ee9bf7996b118ae598 (patch)
treee3b2d79b1e7646a1d3fb8f8a87b8f87c2f0b1231 /configure.ac
parent43de6bba7cc8ac0b0aa4d6065e4e544270e58444 (diff)
configure: Remove AC_HEADER_STDBOOL, AC_C_ and AC_TYPE_ macros
The following macros check if particular C types in specific header file exists, these header files defines them and are already included in the source code. So, remove them. AC_HEADER_STDBOOL - stdbool.h AC_TYPE_INT and AC_TYPE_UINT - stdint.h or inttypes.h AC_TYPE_OFF_T and AC_TYPE_UID_T - sys/types.h AC_TYPE_SIZE_T - stddef.h, string.h, stdlib.h or stdio.h Remove AC_C_CONST and AC_C_INLINE as gcc supports inline and const keywords. Signed-off-by: Varsha Rao <rvarsha016@gmail.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 6ed3edca..13b55748 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,22 +120,6 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h malloc.h \
stddef.h stdint.h stdlib.h string.h unistd.h], ,
AC_MSG_ERROR([Header file not found]))
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
-AC_C_INLINE
-AC_TYPE_OFF_T
-AC_TYPE_SIZE_T
-AC_TYPE_UID_T
-AC_TYPE_INT8_T
-AC_TYPE_INT16_T
-AC_TYPE_INT32_T
-AC_TYPE_INT64_T
-AC_TYPE_UINT8_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-AC_TYPE_UINT64_T
-
# Checks for library functions.
AC_CHECK_FUNCS([memmove memset strchr strdup strerror strtoull])