summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Westphal <fw@strlen.de>2018-04-04 13:50:08 +0200
committerFlorian Westphal <fw@strlen.de>2018-04-04 14:00:02 +0200
commitb2dfb5c9350c58f1025a852d2d78afc5cfa42c5a (patch)
tree160ed1182a30ecd87b8e7e7b441aea7c6c438ac9 /configure.ac
parentaa732e3053e64b62318dd056aac140158c680f8a (diff)
configure: don't enable xtables when --without-xtables is passed
AC_ARG_WITH runs this when EITHER --with-foo or --without-foo is given, so use 'withval'. After this patch: ./configure -> xtables off ./configure --with-xtables -> xtables on ./configure --without-xtables -> xtables off (was on). Reported-by: Alexander Dahl <ada@thorsis.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 284bcc50..eb673d52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,7 @@ AM_CONDITIONAL([BUILD_CLI], [test "x$with_cli" != xno])
AC_ARG_WITH([xtables], [AS_HELP_STRING([--with-xtables],
[Use libxtables for iptables interaction)])],
- [with_libxtables=yes], [with_libxtables=no])
+ [with_libxtables=$withval], [with_libxtables=no])
AS_IF([test "x$with_libxtables" != xno], [
PKG_CHECK_MODULES([XTABLES], [xtables >= 1.6.1])
AC_DEFINE([HAVE_LIBXTABLES], [1], [0])