summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPatrick McHardy <kaber@trash.net>2009-03-18 04:55:00 +0100
committerPatrick McHardy <kaber@trash.net>2009-03-18 04:55:00 +0100
commitfac10ea799fe9b6158d74f66d6ad46536d38a545 (patch)
tree8c093bcbb2144aab54c70103e6ed438456ae0d48 /debian
Initial commitv0.01-alpha1
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore4
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control13
-rw-r--r--debian/copyright4
-rw-r--r--debian/nftables.install1
-rwxr-xr-xdebian/rules20
7 files changed, 49 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 00000000..b1e1dfb4
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,4 @@
+debhelper.log
+nftables.debhelper.log
+nftables/
+tmp/
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..32b17fa1
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+nftables (0.01-alpha1) unstable; urgency=low
+
+ * initial alpha version
+
+ -- Patrick McHardy <kaber@trash.net> Wed, 3 Dec 2008 14:00:00 +0100
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..7f8f011e
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..e0062787
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: nftables
+Section: net
+Priority: optional
+Maintainer: Patrick McHardy <kaber@trash.net>
+Build-Depends: libnl-dev (>= 2.0)
+Standards-Version: 3.8.0
+
+Package: nftables
+Architecture: any
+Priority: optional
+Section: net
+Depends: ${shlibs:Depends}
+Description: Program to control packet filtering rules
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..d6e4857a
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,4 @@
+The GNU General Public License version 2 applies to the upstream
+sources. On Debian systems, the complete text of the GNU General
+Public License version 2 can be found in the
+/usr/share/common-licenses/GPL-2 file.
diff --git a/debian/nftables.install b/debian/nftables.install
new file mode 100644
index 00000000..92e31e96
--- /dev/null
+++ b/debian/nftables.install
@@ -0,0 +1 @@
+src/nft /sbin
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..11988d5b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#! /usr/bin/make -f
+
+configure_opts := --prefix=/ --datarootdir=/usr
+install_opts :=
+
+%:
+ dh $@
+
+build: build-stamp
+build-stamp:
+ dh build --before dh_auto_configure
+ autoreconf
+ dh_auto_configure -- $(configure_opts)
+ dh build --after dh_auto_configure
+ touch $@
+
+install: build
+ dh_install $(install_opts)
+
+binary: install