summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-09-14 11:00:23 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2018-09-18 00:21:19 +0200
commit3bacae9e4a1e34eb09503c5bb8c45b418b6c38b5 (patch)
treec0135d2a161e049e064ec47ad58aa49b8b5ecbe2 /doc/Makefile.am
parentd75e9184bb51a1311ac950b13384f329836d597e (diff)
doc: Review man page building in Makefile.am
Previously, changes to any of the included adoc snippets in nft.txt were not detected and hence the man page not updated (unless 'make clean' was called). It seems like the '.txt.8' target only considers foo.txt when trying to generate foo.8, so get rid of that and introduce a dedicated target for nft.8. While doing so, apply a few other minor changes: * Although nft.8 target has to list all included adoc snippets as a dependency, it is sufficient to call a2x with the main one (i.e., nft.txt) only. * Keep common a2x parameters in a variable. * Use ${A2X} everywhere and hide all calls behind ${AM_V_GEN}, not just the one for nft.8. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e70dfc5e..503d6cd8 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,6 +2,8 @@ if BUILD_MAN
man_MANS = nft.8 libnftables-json.5 libnftables.3
endif
+A2X_OPTS_MANPAGE = --doctype manpage --format manpage -D ${builddir}
+
ASCIIDOC_MAIN = nft.txt
ASCIIDOC_INCLUDES = \
data-types.txt \
@@ -11,14 +13,14 @@ ASCIIDOC_INCLUDES = \
statements.txt
ASCIIDOCS = ${ASCIIDOC_MAIN} ${ASCIIDOC_INCLUDES}
-.txt.8: ${ASCIIDOCS}
- ${AM_V_GEN}${A2X} --doctype manpage --format manpage -D ${builddir} $<
+nft.8: ${ASCIIDOCS}
+ ${AM_V_GEN}${A2X} ${A2X_OPTS_MANPAGE} nft.txt
.adoc.3:
- a2x --doctype manpage --format manpage -D ${builddir} $<
+ ${AM_V_GEN}${A2X} ${A2X_OPTS_MANPAGE} $<
.adoc.5:
- a2x --doctype manpage --format manpage -D ${builddir} $<
+ ${AM_V_GEN}${A2X} ${A2X_OPTS_MANPAGE} $<
EXTRA_DIST = ${ASCIIDOCS} libnftables-json.adoc libnftables.adoc