summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-06-08 17:27:19 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2018-06-11 11:31:49 +0200
commit872f373dc50f702d0956b61ddebe2357cdf04543 (patch)
tree1357490dfd2dd579ccf880d614febedf29d4a337 /doc/Makefile.am
parentf63b54623fcd1ab7d2f51928571c164409f00175 (diff)
doc: Add JSON schema documentation
The document is written as man page in asciidoc which means this adds another dependency to the build system. Though since the (long-term) plan is to replace the docbook-based nft man page with an asciidoc one anyway, we might ultimately get rid of docbook dependency in exchange. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a92de7f5..a4ba30b8 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,9 +1,9 @@
if BUILD_MAN
-man_MANS = nft.8
+man_MANS = nft.8 libnftables-json.5
endif
if BUILD_PDF
-pdf_DATA = nft.pdf
+pdf_DATA = nft.pdf libnftables-json.pdf
endif
pdfdir=${docdir}/pdf
@@ -14,6 +14,15 @@ pdfdir=${docdir}/pdf
.xml.8:
${AM_V_GEN}${DB2MAN} --xinclude $<
-EXTRA_DIST = nft.xml
+.adoc.pdf:
+ a2x --doctype manpage --format pdf $<
-CLEANFILES = nft.pdf nft.8 *~
+.adoc.5:
+ a2x --doctype manpage --format manpage $<
+
+EXTRA_DIST = nft.xml libnftables-json.adoc
+
+CLEANFILES = \
+ nft.pdf nft.8 \
+ libnftables-json.pdf libnftables-json.5 \
+ *~