summaryrefslogtreecommitdiffstats
path: root/py/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2019-05-27 13:36:41 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2019-05-31 18:17:36 +0200
commitef2ff133007855707f978f75ac638af3d5c06fbe (patch)
tree9e270cf8cf1e82499ce1b782eb1307bcb8570637 /py/Makefile.am
parent6d0c815e281c4edc539c535491d6425cf0f8edeb (diff)
py: Implement JSON validation in nftables module
Using jsonschema it is possible to validate any JSON input to make sure it formally conforms with libnftables JSON API requirements. Implement a simple validator class for use within a new Nftables class method 'json_validate' and ship a minimal schema definition along with the package. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/Makefile.am')
-rw-r--r--py/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/py/Makefile.am b/py/Makefile.am
index 0963535d..9fce7c9e 100644
--- a/py/Makefile.am
+++ b/py/Makefile.am
@@ -1,4 +1,4 @@
-EXTRA_DIST = setup.py __init__.py nftables.py
+EXTRA_DIST = setup.py __init__.py nftables.py schema.json
if HAVE_PYTHON