summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2017-10-23 17:33:16 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2017-10-24 15:23:52 +0200
commit49900d448ac95ecabd038a9936d467d6e37aacec (patch)
tree9094e69039de82336c70e466e60f21daf0a8972f /src/Makefile.am
parentd4210b372ac78c8e85ecc6e2317b76daafba15c9 (diff)
libnftables: Move library stuff out of main.c
This creates src/libnftables.c and include/nftables/nftables.h which will become the central elements of libnftables. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 99eef7bb..4d613a73 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -56,7 +56,8 @@ nft_SOURCES = main.c \
mergesort.c \
scanner.l \
tcpopt.c \
- parser_bison.y
+ parser_bison.y \
+ libnftables.c
if BUILD_CLI
nft_SOURCES += cli.c