summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2020-03-04 00:15:30 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2020-03-05 12:39:50 +0100
commit1074015187d54ced41341aeb7f9e6021580ad1d3 (patch)
tree4a429abe788b33ce933440f438fc233cbc9b6801 /src/Makefile.am
parent6ca4dfa45345dc4ac18a83be5e2326bad5a69fe6 (diff)
main: add more information to `nft -V`.
In addition to the package-version and release-name, output the CLI implementation (if any) and whether mini-gmp was used, e.g.: $ ./src/nft -V nftables v0.9.3 (Topsy) cli: linenoise json: yes minigmp: no libxtables: yes [pablo@netfilter.org: add json and libxtables, use -V ] Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9142ab44..3041a933 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,6 +13,15 @@ endif
if BUILD_XTABLES
AM_CPPFLAGS += ${XTABLES_CFLAGS}
endif
+if BUILD_MINIGMP
+AM_CPPFLAGS += -DHAVE_MINIGMP
+endif
+if BUILD_JSON
+AM_CPPFLAGS += -DHAVE_JSON
+endif
+if BUILD_XTABLES
+AM_CPPFLAGS += -DHAVE_XTABLES
+endif
AM_CFLAGS = -Wall \
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations \