summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-12-16 16:37:20 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-12-17 13:15:33 +0100
commit3eaba1125798c7b8f2e8ad3d1a572de6b84f4e5a (patch)
tree319d8f6a1def8554a2838d4cf4e4c2ac05cb7d7b /src/Makefile.am
parent60c655413413360b65ee6bec50012d38a97830cb (diff)
build: remove scanner.c and parser_bison.c with `maintainer-clean`
automake recommends shipping the output of bison and lex in distribution tar-balls and runs bison and lex during `make dist` (this has the advantage that end-users don't need to have bison or lex installed to compile the software). Accordingly, automake also recommends removing these files with `make maintainer-clean` and generates rules to do so. Therefore, remove scanner.c and parser_bison.c from `CLEANFILES`. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 01c12c81..6ab07523 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,8 +2,6 @@ include $(top_srcdir)/Make_global.am
sbin_PROGRAMS = nft
-CLEANFILES = scanner.c parser_bison.c
-
AM_CPPFLAGS = -I$(top_srcdir)/include
AM_CPPFLAGS += -DDEFAULT_INCLUDE_PATH="\"${sysconfdir}\"" \
${LIBMNL_CFLAGS} ${LIBNFTNL_CFLAGS}