summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Kozub <zub.272@gmail.com>2014-11-25 18:51:43 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2014-11-25 18:52:09 +0100
commit57b1eb1ccc074337cc64b86f5bbcedfb583deaeb (patch)
tree9ec4dfb27a2e8f6916eb792f4fc61437ca8c4dc8 /src/Makefile.am
parent7d202f4f956263aeff3693b6ceaa94ebe2799e9f (diff)
build: add missing \ in src/Makefile.am (AM_CPPFLAGS)
The missing \ at the end of the line causes LIBMNL_CFLAGS and LIBNFTNL_CFLAGS to be ignored. This causes build failure if the libmnl or libnftnl headers are not in a path that's already searched by the C compiler. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e8afd464..d53c347d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,7 @@ sbin_PROGRAMS = nft
CLEANFILES = scanner.c parser_bison.c
AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CPPFLAGS += -DDEFAULT_INCLUDE_PATH="\"${sysconfdir}\"" -DDEBUG
+AM_CPPFLAGS += -DDEFAULT_INCLUDE_PATH="\"${sysconfdir}\"" -DDEBUG \
${LIBMNL_CFLAGS} ${LIBNFTNL_CFLAGS}
AM_CFLAGS = -Wall \