summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-05-08 13:08:38 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2018-05-11 12:17:02 +0200
commit586ad210368b775c94acbad2b105483eaf4ca05a (patch)
tree2d6204f59b8d9f7ed7ebed8492739b5e79ec4e0d /src/Makefile.am
parente70354f53e9f6be4a4be31dbc46c5e23291d3587 (diff)
libnftables: Implement JSON parser
If JSON output setting is active in current context, try parsing any input as JSON. If the initial loading of the buffer or filename by libjansson fails, fall back to regular syntax parser. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c5c3b0bc..6db31c81 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -89,7 +89,7 @@ nft_SOURCES += cli.c
endif
if BUILD_JSON
-libnftables_la_SOURCES += json.c
+libnftables_la_SOURCES += json.c parser_json.c
libnftables_la_LIBADD += ${JANSSON_LIBS}
endif