summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2019-07-23 14:30:39 +0200
committerPhil Sutter <phil@nwl.cc>2019-07-30 16:28:54 +0200
commita79f5b729ede4fe39386f2c4971064083631fa7a (patch)
treedf0d668fa22a438324fa82f68bd03bfee4dde88f /src/Makefile.am
parentb608abcbb9600d329677382284a21b32bce5eda2 (diff)
src: Call bison with -Wno-yacc to silence warnings
Bison-3.3 significantly increased warnings for POSIX incompatibilities, it now complains about missing support for %name-prefix, %define, %destructor and string literals. The latter applies to parameter of %name-prefix and all relevant %token statements. Signed-off-by: Phil Sutter <phil@nwl.cc> Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2b53139..740c21f2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,7 +22,7 @@ AM_CFLAGS = -Wall \
-Waggregate-return -Wunused -Wwrite-strings ${GCC_FVISIBILITY_HIDDEN}
-AM_YFLAGS = -d
+AM_YFLAGS = -d -Wno-yacc
BUILT_SOURCES = parser_bison.h