summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1525ac4d..b55b2b1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,9 +24,10 @@ AC_DEFINE([_STDC_FORMAT_MACROS], [], [printf-style format macros])
AC_ARG_ENABLE([debug],
AS_HELP_STRING([--enable-debug], [Enable debugging]),
- [CONFIG_DEBUG="$(echo $enableval | cut -b1)"],
- [CONFIG_DEBUG="y"])
-AC_SUBST([CONFIG_DEBUG])
+ [with_debug=no],
+ [with_debug=yes])
+AC_SUBST(with_debug)
+AM_CONDITIONAL([BUILD_DEBUG], [test "x$with_debug" != xno])
# Checks for programs.
AC_PROG_CC
@@ -128,4 +129,5 @@ AC_OUTPUT
echo "
nft configuration:
- cli support: ${with_cli}"
+ cli support: ${with_cli}
+ enable debugging: ${with_debug}"