summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 316d043e..811d7e22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,11 +49,11 @@ then
fi
# Checks for libraries.
-AC_CHECK_LIB([nl], [nl_socket_alloc], ,
- AC_MSG_ERROR([No suitable version of libnl found]))
+AC_CHECK_LIB([mnl], [mnl_socket_open], ,
+ AC_MSG_ERROR([No suitable version of libmnl found]))
-AC_CHECK_LIB([nl-nf], [nfnl_nft_rule_alloc], ,
- AC_MSG_ERROR([No suitable version of libnl-nf found]))
+AC_CHECK_LIB([nftables], [nft_rule_alloc], ,
+ AC_MSG_ERROR([No suitable version of libnftables found]))
AC_CHECK_LIB([gmp], [__gmpz_init], ,
AC_MSG_ERROR([No suitable version of libgmp found]))