summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-02-01 02:41:27 +0100
committerJan Engelhardt <jengelh@medozas.de>2011-02-01 02:51:54 +0100
commitbf85255e1c813ef208eee77079f14eb5ebe766de (patch)
tree7a74599e116ea53cf6a40bf31cb516b08e549682 /configure.ac
parent6c21436c119cd7ba053937229aeb09dfd25925c2 (diff)
build: avoid use of LIBS variable
The variable contains global libraries linked into every possible object, which is unwanted. Clean up things. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 75372fc..1b799fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,8 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
dnl Checks for libraries.
-AC_CHECK_LIB(dl, dlopen)
+AC_SEARCH_LIBS([dlopen], [dl], [libdl_LIBS="$LIBS"; LIBS=""])
+AC_SUBST([libdl_LIBS])
AC_CHECK_HEADER(pcap.h,HAVE_PCAP_H=true)
dnl Checks for header files.