summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2022-03-08 23:05:39 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2022-03-09 14:00:55 +0100
commitdc454a657f57a5cf143fddc5c1dd87a510c1790a (patch)
treebdf8c613a56d5b7661054bf4576c761e01d333c2 /include/Makefile.am
parent75b3c6a15178a44c6ccff68b79c2bc3a05f7aa28 (diff)
nfct: remove lazy binding
Since cd5135377ac4 ("conntrackd: cthelper: Set up userspace helpers when daemon starts"), userspace conntrack helpers do not depend on a previous invocation of nfct to set up the userspace helpers. Move helper definitions to nfct-extensions/helper.c since existing deployments might still invoke nfct, even if not required anymore. This patch was motivated by the removal of the lazy binding. Phil Sutter says: "For security purposes, distributions might want to pass -Wl,-z,now linker flags to all builds, thereby disabling lazy binding globally. In the past, nfct relied upon lazy binding: It uses the helper objects' parsing functions without but doesn't provide all symbols the objects use." Acked-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 352054e..4741b50 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = linux
+SUBDIRS = linux helpers
noinst_HEADERS = alarm.h jhash.h cache.h linux_list.h linux_rbtree.h \
sync.h conntrackd.h local.h udp.h tcp.h \