summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2020-03-05 17:28:23 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2020-03-09 11:56:12 +0100
commit73dfa4dfe56f748bd419dd79133d4a61e0917e74 (patch)
treedfe6192d8e99d7bb67f53615e61e64302d1f8288 /configure.ac
parentbf8533f529b8d78c54816d83391be833e1db824b (diff)
ip_set: Fix build on kernels without INIT_DEFERRABLE_WORK
There was macro rename in kernel with commit 203b42f73174 ("workqueue: make deferrable delayed_work initializer names consistent") that renames INIT_DELAYED_WORK_DEFERRABLE() to INIT_DEFERRABLE_WORK(). Fixes: 33f08da28324 ("netfilter: ipset: Fix "INFO: rcu detected stall in hash_xxx" reports") Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a03401b..c707755 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,6 +207,16 @@ if test "$BUILDKMOD" == "yes"
then
dnl Check kernel incompatibilities... Ugly like hell
+AC_MSG_CHECKING([kernel source for INIT_DEFERRABLE_WORK])
+if test -f $ksourcedir/include/linux/workqueue.h && \
+ $GREP -q 'INIT_DEFERRABLE_WORK' $ksourcedir/include/linux/workqueue.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_INIT_DEFERRABLE_WORK, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_INIT_DEFERRABLE_WORK, undef)
+fi
+
AC_MSG_CHECKING([kernel source for system_power_efficient_wq])
if test -f $ksourcedir/include/linux/workqueue.h && \
$GREP -q 'system_power_efficient_wq' $ksourcedir/include/linux/workqueue.h; then