summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2020-11-19 13:05:45 +0100
committerJozsef Kadlecsik <kadlec@netfilter.org>2020-11-19 13:05:45 +0100
commit8f1af2e9fe86f3c9ca2925855d1622d7e7b2b708 (patch)
tree4449dd76c1373717024aa5262ab53f290098f2f8 /configure.ac
parent202cfef66b3a1e0988dd384400bd333634816809 (diff)
Compatibility: Check for the fourth arg of list_for_each_entry_rcu()
A forth argument of list_for_each_entry_rcu() was introduced, handle the compatibility issue. Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1058315..7388cdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -746,6 +746,16 @@ else
AC_SUBST(HAVE_SYNCHRONIZE_RCU_BH, undef)
fi
+AC_MSG_CHECKING([kernel source for the fourth arg of list_for_each_entry_rcu() in rculist.h])
+if test -f $ksourcedir/include/linux/rculist.h && \
+ $GREP -q 'define list_for_each_entry_rcu(pos, head, member, cond' $ksourcedir/include/linux/rculist.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_LIST_FOR_EACH_ENTRY_RCU_FOUR_ARGS, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_LIST_FOR_EACH_ENTRY_RCU_FOUR_ARGS, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then