summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhard <jengelh@medozas.de>2008-08-15 13:51:10 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2008-08-15 13:51:10 +0200
commit74e8f2f64575e2e89ca92de9e468389b981c325c (patch)
treefc8f4e4303268af26cddb65bfbdd7a767c640721 /Makefile.am
parentd91bd17eccd00fd392fbd89568bc21a605e84ea9 (diff)
build: fix iptables-static build
Commit 126c1361ad5201973e6ebc761b3e38a67915de29 unfortunately broke building iptables-static due to listing iptables.c twice. Fix this. Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0355e2e1..066dc562 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,7 @@ iptables_save_LDFLAGS = ${iptables_LDFLAGS}
iptables_save_LDADD = ${iptables_LDADD}
# iptables-multi, semi-static
-iptables_static_SOURCES = ${iptables_multi_SOURCES} iptables.c xtables.c
+iptables_static_SOURCES = ${iptables_multi_SOURCES} xtables.c
iptables_static_CFLAGS = ${iptables_multi_CFLAGS} -DNO_SHARED_LIBS=1
iptables_static_LDADD = -lm libiptc/libiptc.a extensions/libext4.a
@@ -63,7 +63,7 @@ ip6tables_save_LDFLAGS = ${ip6tables_LDFLAGS}
ip6tables_save_LDADD = ${ip6tables_LDADD}
# iptables-multi, semi-static
-ip6tables_static_SOURCES = ${ip6tables_multi_SOURCES} ip6tables.c xtables.c
+ip6tables_static_SOURCES = ${ip6tables_multi_SOURCES} xtables.c
ip6tables_static_CFLAGS = ${ip6tables_multi_CFLAGS} -DNO_SHARED_LIBS=1
ip6tables_static_LDADD = -lm libiptc/libiptc.a extensions/libext6.a