summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-01-29 13:32:07 +0000
committerPatrick McHardy <kaber@trash.net>2008-01-29 13:32:07 +0000
commitfb6209a30fd576cd740eefe0a3ad88d65d2bb2b7 (patch)
tree08f9e7c7545c7d4a07179ad0bce3086dbb6e7448 /Makefile.am
parent2b62b62509dfccdb6ebbb17628aad95fb7681a89 (diff)
Give preference to iptables header files
Have the header files in the iptables source tree take precedence over those from the kernel source. Otherwise, building the current iptables from subversion just fails with kernels < 2.6.25. Signed-off-by: Jan Engelhardt <jengelh@computergmbh.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 17c78a7c..a0f33c62 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,10 @@
# -*- Makefile -*-
AUTOMAKE_OPTIONS = foreign subdir-objects
-AM_CFLAGS = ${regular_CFLAGS} -I${top_srcdir}/include
+
+regular_CFLAGS := @regular_CFLAGS@
+kinclude_CFLAGS := @kinclude_CFLAGS@
+AM_CFLAGS = ${regular_CFLAGS} -I${top_srcdir}/include ${kinclude_CFLAGS}
SUBDIRS := extensions
if ENABLE_DEVEL
SUBDIRS += libipq