summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-19 11:52:39 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-19 11:52:39 +0200
commit9475fc45474d9bb57f2f138ad9575fd2593cf2df (patch)
tree8b85f36522a962ad937baf533cce5946576fee57 /configure.ac
parentd8f8f055bdd69c9eb88d84405521180ddce2d718 (diff)
build: do not abuse AM_INIT_AUTOMAKE for autoconf options
Also rename the file to its standard designated name. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5cbbdfd
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+dnl Process this file with autoconf to create configure.
+
+AC_INIT([libmnl], [1.0.0-beta0])
+AC_CANONICAL_SYSTEM
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE
+
+AC_PROG_CC
+AC_EXEEXT
+AM_PROG_LIBTOOL
+AC_SUBST(LIBTOOL_DEPS)
+
+case $target in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, dude!]);;
+esac
+
+AC_OUTPUT(Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg)