summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2022-02-07 14:09:18 +0100
committerPhil Sutter <phil@nwl.cc>2022-02-08 11:00:29 +0100
commit6407868ff8fd6c94f696395e0a7f94973ee893b5 (patch)
treeb727f95394e6f4de89003b081838fd321fab1c9d /tests/Makefile.am
parent41a7bb8f021b7eedfd0f8e40403375dde9db4f9c (diff)
tests: Add simple tests to TESTS variable
This way, 'make check' and 'make distcheck' call them. Omit ct_stress/ct_events_reliable, they require root. For test_connlabel to find qa-connlabel.conf during 'make distcheck', use of 'srcdir' env variable is needed. Add this as a third option to not break existing use-cases. Signed-off-by: Phil Sutter <phil@nwl.cc>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 56c78d9..16fbe6a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,6 +5,8 @@ check_PROGRAMS = test_api test_filter test_connlabel ct_stress \
EXTRA_DIST = qa-connlabel.conf
+TESTS = test_api test_filter test_connlabel
+
test_api_SOURCES = test_api.c
test_api_LDADD = ../src/libnetfilter_conntrack.la