summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Crapet <Matthieu.Crapet@ingenico.com>2014-02-05 14:18:57 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2014-02-12 23:46:55 +0100
commita1b392b4156db984ab2b695a4a70d113f70cb9b8 (patch)
tree92970ba58183f41eaad4463fe32abdaf03e455fd /configure.ac
parent2f22d3c4453135c27873b9014e9dc5b5712804df (diff)
configure: add --without-ipulog option to disable libipulog build
This is a compat library used for netfilter ULOG target. ULOG only works with IPv4. NFLOG has replaced ULOG. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 189a753..88ff7ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,11 @@ case "$host" in
*) AC_MSG_ERROR([Linux only, dude!]);;
esac
+AC_ARG_WITH([ipulog],
+ AC_HELP_STRING([--without-ipulog], [don't build libipulog compat library]),
+ [ipulog_skip=1], [ipulog_skip=0])
+AM_CONDITIONAL([BUILD_IPULOG], [test $ipulog_skip = 0])
+
dnl Dependencies
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 0.0.41])