summaryrefslogtreecommitdiffstats
path: root/_conntrack/configure.in
diff options
context:
space:
mode:
author/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-07-30 21:10:38 +0000
committer/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-07-30 21:10:38 +0000
commit12420ece58cabc4c9c67f3256a28f814664de24e (patch)
tree05bf316063d97d423b5dffcfb3d6e81e18b0bc81 /_conntrack/configure.in
parente76b48e39bd1129ddd5a198cbca90877b3ff9735 (diff)
restructuring libctnetlink -> libnfnetlink_conntrack
Diffstat (limited to '_conntrack/configure.in')
-rw-r--r--_conntrack/configure.in63
1 files changed, 59 insertions, 4 deletions
diff --git a/_conntrack/configure.in b/_conntrack/configure.in
index 2e835d9..1516c80 100644
--- a/_conntrack/configure.in
+++ b/_conntrack/configure.in
@@ -1,12 +1,67 @@
dnl Process this file with autoconf to create configure.
-AC_INIT(libctnetlink.c)
-AM_INIT_AUTOMAKE(libctnetlink, 1.04)
+AC_INIT
+
+AC_CANONICAL_SYSTEM
+
+AM_INIT_AUTOMAKE(libnfnetlink_conntrack, 0.10)
AC_PROG_CC
-AC_EXEEXT
AM_PROG_LIBTOOL
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
AC_SUBST(LIBTOOL_DEPS)
+case $target in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, dude!]);;
+esac
+
+AC_CHECK_LIB([nfnetlink], [nfnl_listen])
+
+
+
+dnl--------------------------------
+
+AC_DEFUN([NF_KERNEL_SOURCE],[
+
+ if test "$with_kernel" = ""; then
+ KERNEL="`uname -r`"
+ else
+ KERNEL="$with_kernel"
+ fi
+
+ THIS_PREFIX=""
+ for i in "/lib/modules/$KERNEL/build/include" "$KERNEL" "$KERNEL/include" "/usr/src/linux-$KERNEL" "/usr/src/kernel-$KERNEL" "/usr/src/linux-headers-$KERNEL" "/usr/src/kernel-headers-$KERNEL"
+ do
+ AC_MSG_CHECKING([Looking for kernel source or headers in $i])
+ if test -r "$i/linux/config.h"
+ then
+ THIS_PREFIX="$i"
+ AC_MSG_RESULT([found])
+ break
+ fi
+ AC_MSG_RESULT([ ])
+ done
+ if test -r "$THIS_PREFIX/linux/config.h" ; then
+ AC_SUBST(KERNELDIR,[$THIS_PREFIX])
+ AC_MSG_RESULT([found])
+ else
+ AC_MSG_ERROR([not found $THIS_PREFIX])
+ fi
+
+ # somehow add this as an include path
+])
+
+AC_ARG_WITH(kernel,
+ AC_HELP_STRING([--with-kernel=DIR],
+ [ Show location of kernel source. Default is to use uname -r and look in /lib/modules/KERNEL/build/include. ]),
+ NF_KERNEL_SOURCE($with_kernel),NF_KERNEL_SOURCE())
+
+dnl--------------------------------
+
+
dnl Output the makefile
-AC_OUTPUT(Makefile)
+AC_OUTPUT(Makefile src/Makefile include/Makefile include/libnfnetlink_conntrack/Makefile utils/Makefile)
+